Tutorials

Hier werden fortlaufend Tutorials veröffentlich, die wir im Kontext von Kinect und Cinema 4D erstellen.

Tutorial 1

Damit ihr die Kinect überhaupt mit eurem Mac betreiben könnt, müsst ihr zuerst die notwendigen Treiber und eine Tracking-Software installieren. Weil das für einen normalen User oft eine Hürde ist, da hierzu die Eingabe über das Terminal notwendig ist, zeigen wir euch mit diesem Tutorial Schritt für Schritt, wie die Treiber und die Tracking-Software OSCeleton installiert werden. Zudem zeigen wir auch, wie ihr das entsprechende Plugin installiert, um die Tracking-Daten an Cinema 4D zu übergeben.

In diesem Tutorial verwenden wir exemplarisch Mac OS/X 10.6 (Snow Leopard) und Cinema 4D R14. Wir wissen, dass das Plugin ab dem Release 12 zuverlässig funktioniert.

Und hier folgt das Tutorial noch als PDF zum Download: Tutorial 1

Wichtig für alle User von Mac OS X Lion (10.7) und Mountain Lion (10.8): Ihr müsst zuerst dieser Anleitung folgen.

 

 

Tutorial 2

Ein einfaches Joint-Template für Cinema 4D (ab R12) findet ihr in unserem Download Bereich. Wie ihr das mit dem KiCapOSC-Plugin an die Kinect bindet, veranschaulicht euch das kurze Video hier.

7 Gedanken zu „Tutorials“

  1. Hallo Zusammen

    Verwendet ihr die Kinect für Xbox, oder für Windows.

    Wir bekommen die Kinect über Mac zwar zum laufen, aber leider verliert er nach wenigen Sekunden die Verbindung.

    Übrigens eine super Idee mit der Kinaction Platform!

    Grüsse
    David

    1. Hi David,

      wir verwenden beide und haben kein Unterschied festgestellt…

      denke das wird eher an der Software liegen.

      wie sieht eure Arbeitsumgebung aus?

      vg
      Matthias

      1. Hallo Matthias

        Unsere Umgebung ist wie folgt:

        MacPro
        Prozessor 2x 2.93 GHz 6-Core Intel Xeon
        Memory: 16 GB 1333 MHz DDR3
        OSX Lion 10.7.5
        Cinema 4D R14
        Kinect angschlossen an front usb (die hinteren usb haben wir auch probiert)

        Installation der packages haben wir gem. Eurem Tutorial gemacht.

  2. He David,

    wir arbeiten momentan auf 10.6 und da geht alles gut.

    10.7 haben wir nicht probiert, da wir selber nicht zufrieden sind mit 10.7 als OS an sich.

    wir haben es unter 10.8 probiert und da läuft es auf verschiedenen mac-books aber komischerweise nicht auf unserem mac-pro.

    haben in der Recherche mit bekommen, dass es wohl Probleme gibt, wenn von 10.6 auf 10.7 geupdated wurde.

    probiert bitte erstmal mit Kinecta (Good-2-Know) euch zu tracken (ohne Cinema) und gebt bitte feedback ob es länger funktioniert als ein paar sekunden

    1. Hallo Matthias

      Nun haben wir es über Kinecta versucht. Da erhalten wir allerdings gar kein Referenzbild. (Die framerate springt lediglich um die 600 herum)

      Nächster Versuch war über oxs 10.8.2 auf einem mac-book pro. Passiert das selbe wie auf 10.7.5 (nach start von osceleton: looking for user… new user 1…. calibration started for user 1… dann erlischt an der Kinect das rote Infrarotlicht und im terminal passiert nichts mehr.)

      Wir haben nun auf windows über die sdk getestet, ob eventuell etwas (hardware seitig) an der kinect nicht stimmt. funktioniert jedoch und zeigt auch video an.

      Wenn wir alles beachtet haben, was ihr im tutorial gezeigt habt, müsst es eingenlich funktionieren, oder haben wir was über sehen (zusätzliche Software welche auf dem mac installiert sein muss, oder ein firmware upgrade der kinect?)

      Das lässt uns jetzt keine Ruhe…. ;o)
      Vielen herzlichen Dank für alle Tips
      Grüsse
      David

  3. Hallo Steffen

    Vielen Dank für Eure Tips. Wir ware auch schon auf diesem Weg.

    Nun ist allerdings das Problem, dass nach der Installation von libtool und dem Neustart Ende ist.

    Bei der port install libusb + universal kommt folgende Fehlermeldung:
    Error: Port + not found
    ComputerName:~ ComputerName$ sudo port install libusb + universal
    —> Cleaning libusb
    Error: Port + not found

    Das jetzige System:
    10.7.5
    Alle tools die ihr angegeben hat wurden erfolgreich installiert. (bis auf den cleaning libusb)

    Eine Idee was das Problem sein könnte?

    Beste Grüsse
    David

Kommentare sind geschlossen.